O correio da internet primitivo era apenas ASCII, então o corpo de uma mensagem não podia carregar uma imagem ou um arquivo de uma forma com que todos os clientes concordassem. O MIME, as Multipurpose Internet Mail Extensions, foi concebido para mudar isso.

O MIME surgiu do Andrew Messaging System na Universidade Carnegie Mellon como um formato de dados multiplataforma, e foi especificado pela primeira vez pelo cocriador Nathaniel Borenstein e outros como a RFC 1341 em junho de 1992; a versão atual é o conjunto RFC 2045/2046/2047 de 1996.

Seu projeto era deliberadamente pequeno: um cabeçalho Content-Type nomeia o que é a parte, um Content-Transfer-Encoding converte binário em ASCII, e uma fronteira multipart permite que um corpo contenha muitas partes. A mensagem ainda trafega pelo SMTP como antes.

Como a extensão era baseada em cabeçalho e opcional, cada cliente podia adicionar suporte no seu próprio ritmo, e o MIME rapidamente se tornou a forma padrão de enviar anexos e e-mail com rich text, e mais tarde a base da própria ideia de content-type da web.

Adicionar um cabeçalho que diz o que é o corpo

Um cabeçalho content-type diz ao receptor o que é uma parte, para que ele possa decodificar por regra

base64 permite que binário arbitrário passe por um transporte apenas ASCII

Fronteiras multipart permitem que uma mensagem contenha texto e anexos juntos

Como a mudança era no nível do cabeçalho, a adoção não exigiu uma troca comum

Para estender um sistema amplamente implantado, adicione uma pequena peça opcional de estrutura, não um novo sistema: um cabeçalho dizendo o que é o payload permite que cada implementador o adote por conta própria.

O MIME se tornou o contêiner universal para anexos de e-mail e é a razão pela qual o cabeçalho Content-Type tomou emprestada sua ideia para descrever recursos da web. A especificação original era fraca em apresentação, então o Content-Disposition foi adicionado na RFC 2183; na prática, muitos clientes ainda escolhem a parte a exibir usando sua própria lógica em vez do conselho do padrão.

CONFIRA AS EVIDÊNCIAS

As fontes

  1. Multipurpose Internet Mail Extensions (MIME) Part One (RFC 2045) IETF / rfc-editor.org · rfc-editor.org
  2. MIME — Wikipedia Wikipedia · en.wikipedia.org